Jump to content
Sign in to follow this  
Trombe

Copy & Paste Japanese fonts

Recommended Posts

In this old "new" Tainted World site, when I copy from Japanese websites and paste here, all Japanese fonts and symbols are changed to strange signs (referred to my posts in News Forum). But I noted that other members could post Japanese fonts properly

I would like to inquire how such problem could be resolved

Share this post


Link to post
Share on other sites

I have no clue really. As you said, it works fine for me, whether I copypaste the japanese or input it manually.

Do they turn to gibberish right after you copied them in, or only after you posted them?

Share this post


Link to post
Share on other sites

Well, I'll look into it, but I can't reproduce this error. I only see gibberish in the preview, but once I post it, the japanese is fine. Maybe try setting your browser to different encodings (Japanese, Unicode, etc), or only copy and paste with the japanese input enabled.

What OS and browser do you use anyway?

Share this post


Link to post
Share on other sites

So... did you try the options I gave you?

Because everybody else seems to able to use copied kanji. At least I haven't heard any other complaints so far. Or is anybody else having problems?

Share this post


Link to post
Share on other sites

Don't have any problems myself.

However, the OP's problem does sound like a language encoding problem. The fact he says it's to do with this site (you didn't mention other sites, so I am assuming it works fine with others), rules out any language encoding for your OS itself, so as Champ123 as suggested, I would definitely try the language encoding within your browser, otherwise I'd try it with a different browser and see if you get the same problem. It's definitely a weird one, if you get the same problem with a different browser I'd start looking at your language encodings for OS, but I can't see that being the problem if you are fine with other websites.

Share this post


Link to post
Share on other sites
Well, I'll look into it, but I can't reproduce this error. I only see gibberish in the preview, but once I post it, the japanese is fine. Maybe try setting your browser to different encodings (Japanese, Unicode, etc), or only copy and paste with the japanese input enabled.

What OS and browser do you use anyway?

in fact I've tried to set the browser to various codings (Japanese, Unicode, Western European etc) before pasting the Japanese input, but gibberish is still shown...I don't know why

and such problems did not exist in other websites I visited

Share this post


Link to post
Share on other sites

I have kinda the same problem, but only if i want to "Preview" what I've just wrote, only then the japanese is turned to ")#()%#)="()¤)=")-" but when I click the "Add Reply" button it's in Japanese again.

Probably should fix so the Preview-mode is in UTF-8 too and not ANSI

Share this post


Link to post
Share on other sites

The options of configuration and costumization are somewhat more limited here.... it is a free forum and hosting after all. It was supposed to be temporary, but it might become a bit more permanent as it's becoming increasingly unlikely that Dai will ever fix the old one.

In the long term we want to move to our own hosting again, but I think we will be here for at least a few months. So for now we probably have to live with some minor bugs. I had a look at the css for the board theme, but I couldn't really find any options to temper with character coding.... not that I know much about css to begin with. It also seems to do that preview thing with any theme we have installed at the moment, so it probably isn't theme-related at all, and we can't really go deeper into the code than that anyway.

Either way, I'm still at loss why Trombe can't post any Japanese at all. It shouldn't do that.

So I'd ask you again to post some japanese in here so I can see exactly how it ends up and what might be done to fix it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...